20S does not lock onto its base

Kommentare

175 Kommentare

  • Christophe Larrosa
    Christophe Larrosa

    Well, I actually discovered this morning that the unit I manage to lock onto its base (and that I vowed to never touch again) is actually broken. One of the anchor points at the front is broken, so the unit is loose and looks like it wants to open in 2 halves. Obviously, water resistance is shot as a result. I'm going to return the units. Not sure if I want to make an exchange or just return them and buy a set of spare mounting bases for my SMH10.

    The 20S introduced a lot of new nice features but its build is incredibly and embarrassingly flimsy for such a top dollar product. Hugely disappointed...

     

    0
  • Robert Whitelaw
    Robert Whitelaw

    So just thought I would mention that Sena took good care of me. Quickly sent out a replacement. All they asked for was the main unit and the bracket for the RMA, but they sent me a whole knew kit. This ended up working nicely since I noticed I was getting some distortion in one of the speakers anyway.

    One thing I thought I would mention is that I have been trying to figure out what would cause this issue and after paying close attention to how I use the device, I think I have an idea. I frequently skip tracks when music is playing. This means I push and rotate the dial on the unit a whole lot. I tend to do this on the back and or top of the dial. It seems to me that by putting pressure on that area over and over, it is likely to put stress on that locking mechanism. Just a thought.

    0
  • David Moss
    David Moss

    Same issue here.  The latch no longer protrudes far enough to engage the electronic module.  Opened a ticket today.

    0
  • David Moss
    David Moss

    I bent a wire coat hanger to hold the module on the back plate. Will allow the unit to work until my trouble ticket is resolved.




    14 - 1.jpg
    0
  • Mathew, Bruce
    Mathew, Bruce

    My unit is about 30 days old.  It's been snapping on just fine for all the times until yesterday when I noticed it would no longer lock on.  I've discovered that the latch itself appears to be broken - if I just push on it, it goes into the slot but does not  spring back out to lock the unit on.   

    0
  • Christophe Larrosa
    Christophe Larrosa

    It's such a shame really. I would really like the 20S to work! But I'm really leaning towards a straight return as opposed to an exchange, as there is obviously an issue with the design/quality/manufacturing of the 20S and any exchange, until it has been addressed,  would be a lottery, with pretty bad odds. The SMH10 was so much sturdier!

    0
  • Robert Whitelaw
    Robert Whitelaw

    I know where you are coming from. I had the same thought. However, the warranty period is what had me lean more toward sticking with it.

    0
  • Christophe Larrosa
    Christophe Larrosa

    Ha ha ha... And I have looped a rubber band around mine to make sure it does not open in 2 and stays in place. Still... unacceptable on such a product.

    0
  • Bland Ellen
    Bland Ellen

    Have the same connection problem. Sena said they would send an email with return info but have not received it yet. Extremely disappointed in this produce.

    0
  • Mathew, Bruce
    Mathew, Bruce

    I think I figured out what is happening.  I'm betting it's actually an "over design" problem.  The rubber seal around the connection pins is working too well - it keeps the moisture out, but it creates too much pressure.  The issue that it creates so much pressure on the latch, that when the silver button is pushed, it's not releasing until it's over stressing the latch arm inside the mechanism and it's breaking the arm.  My system was fine until the last time I released the latch, then it would not lock on again.  The ideal solution would be to make the arm out of metal instead of plastic.  But I'm guessing that sooner than later with that much pressure the plastic slot where the latch connects would also wear out unless it's also metal.

     

    0
  • Christophe Larrosa
    Christophe Larrosa

    Alright, I have opted for an exchange. I'm giving the 20S another chance, especially in view of the 2-year warranty, as mentioned above by another poster, and also because the response from Sena has been pretty good.

    That being said, I still think it's a lottery, with bad odds at that, but we'll see...

    0
  • Bob Boehmer
    Bob Boehmer

    I received my exchange.  My plan is to remove the bluetooth unit from the base as infrequently as possible.  I'll charge it while it's on the helmet...

    I have to say, Sena support has been great.

     

    0
  • Ra;ndy Bornhorst
    Ra;ndy Bornhorst
    Same locking issue
    Locked with difficulty at first.
    Now won't latch anymore.
    No response yet after contacting them
    0
  • Mathew, Bruce
    Mathew, Bruce

    Well, I'm disappointed.  I bought this unit specifically for a trip I'm leaving for in the morning.  Received it a few weeks ago - I've maybe had the unit off the base 2 dozen times.  Now it's broken for the trip I planned for it with others.  I never expected to pay this much for something and then have it break to the point it can't be used in just a few days.  And I've had no response from support - I've emailed, I've created a work order on this site and I've tried to reach them via phone with no results.  I'm about to go public on their FaceBook Page and see if that gets some attention....

    I've now resorted to a crappy zip tie solution so I can at least try to use it on my trip....  I'm betting the others in my group won't be impressed with SENA when they see the ZIP TIE...  I love the performance of this 20S, but I'm totally embarrassed by my purchase choice at this point...  I'm sure the CARDO guys in the group will be telling me how stupid I am....

    If I ever hear from them and if I do get the base replaced, I won't be removing it once it's locked on....  A very nice feature that I paid for and can't use....  The quality testing boys had better be fired if they haven't been already - 24 cycles of a latch and it breaks should have never made it out of the test lab....




    20140903_211506.jpg
    0
  • Christophe Larrosa
    Christophe Larrosa

    Ha ha ha... Sorry, I'm just laughing at the pic, because mine was even worse as I had a green rubber band looped in there instead of your rather tidy zip tie.
    I totally understand your disappointment. Mine is about to be picked up by UPS right now and I'll see what the exchange unit is like when it gets there.

    It did take SENA a few days to get back to me after I opened the ticket, but once they got back to me, communication with them was pretty good. Same thing with Sena Europe, handling the return. That's their saving grace and one of the reasons, besides the 2-year warranty, that I went for an exchange instead of a refund. That and my unbridled optimism (probably misplaced) I guess...

    0
  • Smokey
    Smokey

    Same here, pretty poor for a set that costs as much as it does, I am going to call the place I purchased it at and get a replacement.

    0
  • Smokey
    Smokey

    I just opened a ticket as well, I have also contacted my dealer to see if they will replace it from another set, this is poor quality control IMO and for a high priced product is inexcusable. I will see what they say and if need be I will call SENA and talk to them.

    0
  • Smokey
    Smokey

    Well I resorted to taking the backing plate apart, the locking tab is broken inside, it is snapped (plastic which explains it) right across the part were the release pin pushes on the tab. Cheap crap and I am almost tempted to return it if they don't answer my complaint, now on hold for ten minutes with technical support.

    0
  • Ashwin Mathias
    Ashwin Mathias

    The locking mechanism is weak and poorly designed. Tech support was responsive for me, once the issue was identified. Took 2 weeks for an RMA and receipt of a new set. As with others, without a design change the problem will continue to happen.The zip tie solution looks good though for a short term fix.

    0
  • Smokey
    Smokey

    I will not be waiting two weeks, I have submitted an RMA but in the meantime I do not want to be without the unit as I listen to my IPod over the bluetooth, I resorted to a temporary fix of using crazy glue to glue the broken pieces together and reinforced with a thin strip of plastic along the crack, also crazy glued making sure it does not interfere with the spring, seems to be working so far and it now locks in place. I am still submitting an rma though for a replacement part. Tech support was also responsive after I called their 866-300-1235 and 408-300-9797 numbers.

    0
  • Smokey
    Smokey

    I also highly recommended they look at making that piece out of aluminum, as they will just experience the same problems, either that or the spring is to strong and puts too much pressure on the locking tab.

    0
  • dgreen
    dgreen

    I think the core issue is the weather seal around the base unit contacts.  It's too stiff which puts excessive force on the locking tab which is too small and too weak.  Releasing the main unit requires compression against the seal before pressing the silver button.  Don't do that and it's easy to see how the locking tab will break in a few uses. Long term though, I'll still expect it to fail from the constant force due to the weather seal.

    0
  • Smokey
    Smokey

    Good point, I tried both ways, pushing down and then pushing the release, and just pushing the release, I couldn't really see much difference but I can see your point for sure on the extra stress that would put on the release tab.

    0
  • Christophe Larrosa
    Christophe Larrosa

    Great! Just received the replacement... I sent back the whole Dual Kit and what I got back was the same box, the contents of which were stripped of both clamps and main units. Alongside was 1 unit and 1 clamp kit.

    Isn't it great? After having to deal with a design/manufacturing flaw, I end up with a single kit when I bought a dual kit... 

    I asked for them to send me the missing unit + clamp.

    I have not tried the new one yet... I would not be surprised for it to give the same problem or a totally different one at that point... sigh...

    0
  • Smokey
    Smokey

    They are sending me a replacement, but told me the old one is not needed

    0
  • gareth evans
    gareth evans

    i am totally gutted to find this chain. I received my 20s yesterday - and the same issue - it locks into place but it rocks in the cradle so useless, should have been such a simple thing to get right. Amazon are sending me a replacement  - great service. here's hoping i wont have to send the new one back. If i do - it'll be buying a new hardwired Autocom - (my 7 year old system had finally given up,).

    0
  • Smokey
    Smokey

    Gareth, make sure you let Sena know as well by opening up a ticket, there is no excuse for this on their part and I am sure they must have had some fail, that is if they even tested them to begin with, so far my fix for the one that is broken seems to be working and the part has not broken again, but now when I remove the module I make sure I squeeze the module and the base together to take some of the stress off the locking tab. I would also call them by phone, they do not seem to answer the work ticket submissions in a timely manner.

    0
  • Bland Ellen
    Bland Ellen

    Just got my replacements today. They actually sent the entire duel 20s kit. Took about 10 days from the time I first contacted customer service. New units locked and work fine, but I can see no obvious change or upgrade to the units so I'll take them on and off gently. So far I have been pleased with their response. We'll see how these work in the long term.

    0
  • spoonyfork
    spoonyfork

    Same thing happened to me right after the front screw housing broke... my Sena 20S will no longer latch in. I love the zip tie fix!

    0
  • Soren Hejnfelt
    Soren Hejnfelt

    I had this issue as well. The dealer replaced it but SENA support also suggested that I should "seek" a replacement with their US office even though I am in Europe. http://prntscr.com/4mo9xd

    0

Bitte melden Sie sich an, um einen Kommentar zu hinterlassen.