Once Again, Failure


17 Kommentare

  • mark

    For the sake of any other poor bugger out there who happens to own a Sena product and experience this problem: I was able to make that error message go away by rebooting my computer.

    I shouldn't have to do that after doing an upgrade to the Manager app which was prompted >>by the manager app<<. Most companies learned how to handle seamless upgrades like that years ago...but some are slower learners than others.

    Now I'm off to figure out what else got screwed up by the upgrade.

  • pav

    I'm updating my 10s and I got the same error, restarting my computer did not help. Here's how I got around the error. This is a work around and I am not responsible for a failed firmware update, just sharing what worked for me. 

    When you get the error prompt the background notes will tell you how to prep your SENA, for my case it told me to hold the phone button for 5 seconds. With the 'incorrect parameter' error up I did exactly that. Windows gave me a USB connect tone. 

    This is the tricky part, you want to mouse over the 'Next' button and quickly hit enter to make the error go away and at the same time click the 'Next' button. Voila you should get a prompt to update firmware. The rest should work as it should. 

    Frankly this is kind of embarrassing on Sena's part.

    I got this error while running a Windows 10 system with the October update. 8th Gen i7 with 32Gb of ram. I am running Sena Bluetooth Devise Manager v3.8.4 Can send the whole system spec if Sena wants to troubleshoot. 

  • Mltbmiller

    Thanks "pav", your tricky solution worked for me.


  • dozzy

    I experienced the same problem. I managed to get around it by clicking next fast enough before the blocking pop up appears. 

  • Gyshire

    How the hell does this kind of crap get past QA?  Seriously

  • Huey van Zijl
    Huey van Zijl


    Indeed, quickly clicking also worked here. Compatibility mode in Windows 10 also didn't fix it. So all you owners out here, click like crazy!

  • Peter Quigley
    Peter Quigley

    Use a USB 2.0 port and it will work.

  • Sena Support
    Sena Support

    Hi everyone. This issue is caused by the latest build of Windows 10 and our developers are looking into it. In the mean time, you can drag the "Incorrect parameter" prompt so that it's not on top of the Sena Device Manager, click the OK button on the prompt and then hit the NEXT button on the Sena Device Manager after following the instructions to have your device recognized.


    If you're still having issues with the Sena Device Manager, please contact our Customer Service department by visiting https://www.sena.com/support/submit-ticket to submit a ticket or send an e-mail to support@sena.com to contact them. Thanks.

  • Todd Joyce
    Todd Joyce

    That solution does not work for me. Can not see USB port.... Sena has the absolute worst software in the entire communications industry. Hands down.


  • mrosselet

    It really sad when they sale a device and you can't upgrade it. I have had the Sena 10S and really liked it so I was going to purchase another one for a different helmet. Before I did I wanted to upgrade mine to the latest firmware and had the same issue with Windows10. After talking to the so called Customer Service/programmers many times they told me that since I didn't have the receipt I was out of luck and they wouldn't do anything so I opted out of purchasing the other helmet because of lack of support. I will try what I have read on here and hopefully it will work. I was never told to try and you would think that support could figure this out and if it is a problem get their program fixed so that you don't need to play the games- but maybe they make more sales this way- who knows. But thanks for the information. Hope it works so that I can keep at least one helmet going. 

  • Steve paxman
    Steve paxman

    Cheers Pav that worked for me, I had to hold down the volume down button and windows paired with the lid

  • Josh G
    Josh G

    Since this seems to be the only post coming up in Google for Sena Firmware issues, figured I would leave my findings in here as well. Latest version of Windows 10, upgrading firmware on a 20s, I resolved the issue by plugging the device directly into the USB ports on the PC instead of through a hub as I had been doing previously. 

    I was getting the error "Failed to update firmware. Cannot get status." initially, after I installed a new version of the Sena Device Manager. Attempted restart and after that Discovering the device became an issue but unplugging and plugging back in would eventually get it to pair. Would still give the error "Cannot get status" Until I plugged into a USB port directly on the PC rather than through a USB 2.0 Hub which was more easily accessible to me. Hope this helps someone out!

  • cameron carewicz
    cameron carewicz

    Windows 10:

    Post is a little old. But if none of the above methods work (they didn't work for me) run the application in win 7 compatibility mode and run it as admin. Hopefully this will help the devs out as well.


  • Michel Windholz
    Michel Windholz

    I had the same issue as "Josh G" the error "Failed to update firmware. Cannot get status."

    This worked for me! thanks mate

  • Samuli Välimäki
    Samuli Välimäki

    It's 2021 and the Device Manager still doesn't work on MacOS and the mobile app is horrible and not optimized for recent iPhones... Since the day one i've owned Sena, the app has been a huge disappointment.

    Contact me if you need a software developer from this century...

  • Mohanraj B
    Mohanraj B

    It's worked for me. I followed "Josh G". Thanks dude..!

  • Peter

    Are you kidding me? Here I am, 5 years later after the first question.

    I followed all the FAQ steps from Sena, but nothing worked.
    Now I've tried this step from PAV, and it's updating now.

    After it says you have a new update, do you want to save it somewhere? You need to be prepared.
    Once you've selected the location of the file and hit save, you need to click Next faster than the flash.
    That's all. So, I started clicking like crazy, and it worked.

    dont press the update button, just stay with the next button and you are saved.


    Keywords for finding this topic:
    Sena, update, could not find 30k, cannot get status 6, Failed to update



Bitte melden Sie sich an, um einen Kommentar zu hinterlassen.