New Bilt DWO-5 Helmet



  • Victor M Cotto
    Victor M Cotto

    So I have the Same Problem Kevin H is having. My system is Windows 10 64K. And it does not open the USB port to talk to the Helmet. What's up with this? 

    Also, when trying to Pair the DWO-5 to  my Bike, the pins don't match. How can I change the Pinto pair the helmet to my bike?


  • Mariah Kraft
    Mariah Kraft

    I am having the same problem Kevin H had. My computer doesn't recognize the device and I do not have a MAC to use, only a PC Windows 10 64bit. 

    How can I resolve this? 

    I would like to pair my DWO-5 with my phone but nothing is working. I thought a driver/firmware update was in order since I haven't updated it since I purchased it.

  • Roy Crawford
    Roy Crawford

    In case anyone else sees this post the fix is to disable Driver Signature Enforcement. I got a helmet yesterday and had this same problem. Disabled that and it worked after that. Here is a link for how to do it or just google it yourself.

    ***Disclaimer*** Cyclegear, Sena nor I are to be held responsible for any changes you make to your system. Make these changes at your own risk.

  • Terry L. Hitt
    Terry L. Hitt

    NEW CYCLE GEAR BLUETOOTH DEVICE MANAGER software v1.3 is available, it worked fine for me... did not find any newer firmware available from server for my Bilt Modular Full Face Techno


  • Marc Delpouys
    Marc Delpouys

    I had the same issue of the device being unrecognizable.  In Device Manager it had the Bilt DWO with yellow exclamation point. 

    I looked at the USB cable that came with the helmet and it said USB 2.  I looked at Device Manager and laptop only has USB 3.

    I then tried using my old desktop with has USB 2 and it worked as expected.  No errors in device manager or the CycleGear updating app 

  • Christina Jones
    Christina Jones

    When setting up my cousins helmet after she gave up I found that when it says the device is not found I needed to Hold the center button continually to get it to recognize the device and to get the  update installed. This was frustrating but it did accomplish the goal 


Please sign in to leave a comment.