SMH5 1.1 to 1.2 firmware upgrade fail

Comments

37 comments

  • Robbin Hertogs
    Robbin Hertogs

    Same problem over here. Updating my headset (SMH5) to v2.2.1 failed at 90%. Afterwards the headset didn't respond at all, manual 'hard reset' at the back didn't work. 

    Solution: !ORIGINAL! usb cable seemed to fix everything.

     

    Good luck!

    0
  • Janet
    Janet

    My SMH5 was completely dead after firmware upgrade failed. Tried everything I can find on the forum. I'm not completely sure what actually made it work. But the last thing I tried was to uninstall the device manager I downloaded from SENA's Device Manager page via "Download Firmware via Device Manager" (filename: SENABluetoothDeviceManagerForMAC-v3.3.pkg), then installed an older version device manager which I believe was prompt by the device manager already on my mac to download (filename: SENABluetoothDeviceManagerForMAC-v2.6.pkg). The steps shown in the 2.6 device manager is similar to troubleshooting instructions posted by 3735. The firmware update actually got stuck on 99%. But that was enough to revive the SMH5 to be able to power-on and the firmware upgrade was completed. 

    0
  • j
    j

    My SMH5 was also completely dead after tryind to update and got stuck to 90%. I uninstalled / installed the sena device manager several times until the sena was automatically detected, went through device recognition and was brought back to life. No need to say I won't do firware updates in the future. Hope this makes sense and will help someone.

    0
  • tran anh tuan
    tran anh tuan

    finally i can solved for my SMH5 stuck loading to 90% . i uninstalled/ installed the sena device manager then i press and hold phone button for 10 second and wait for recognize usb sound from systems then chat log will show up and i press and hold dialog and phone button same time for 5 second and done . It's work for me . Hope this will help someone else

    0
  • Dan D
    Dan D

    while doing the initial update, it asked me to press the phone button at about 25-30%. I did that and it continued but got stuck at 90%. After waiting about 20 minutes, I unplugged it to see that it wasnt working at all.

    I tried resetting it with the pin hole at the back, but couldnt tell if it was doing anything and it wouldnt power up.

    I read a post hear saying to turn off wifi (put my computer in airplane mode) and to just reinstall the software again. I did that, it detected the hardware again, and it prompted to download new firmware again, (even though im offline) so i did that, it started loading the firmware again, and at 90% it asked me to press the jog dial and phone button at the same time until the yellow window went off. 

    After that it hit 100% in no time and it works great now

    0
  • Gonzalo Lorca
    Gonzalo Lorca

    Guys

     

    Use Sena Update Manager with Admin Privileges. Execute it with right click -> run as administrator.

    Problem solved.


    Greetings!

    0
  • Mike Fields
    Mike Fields

    90% HANG PROBLEM SOLVED: Must use a USB 2.0 Port (NOT 3.0) on your computer with original USB cable. After a few seconds at 90%, you'll get a yellow pop-up screen instructing to hold center and + buttons until pop-up disappears (worked for my SMH10R after a lot of troubleshooting). You do, it does, and completes to 100%.

    0

Please sign in to leave a comment.