Sena 10 C problem with SD card



  • Curtis Ide
    Curtis Ide

    I had the same problem when I just tried to update the device to firmware 1.0.4

  • Roadside

    I upgraded the same software version and it seemed to stop my issue, so far it hasn't done it since the upgrade.   

  • Robert Canales
    Robert Canales

    I have had the worst experience with Tech support trying to update a newly purchased 10c... Tech Support even said try another cable because the brand new may be defective. They then offered to have me send in unit for them to update firmware because SD card not found error happening after trying everything except obviously the correct resolution. I mentioned I need it back within a time frame so I return if I don't like device, since I haven't used it since update wont work. Tech support closed the ticket on me and said sending it back to vendor of purchase will fix it. REALLY!

  • beans

    make sure you have 32GB or lower capacity SD card. a higher capacity SD card might be a problem when updating the firmware. 

    try formatting the SD card in the 10C and then try to update it again.

    try a different SD card.

  • Robert Canales
    Robert Canales
    Djj...ive tried every but the switching sd card... Im using San Disk Ultra class 10 32gb and its not allowing format to get past 16% and I cant record video either, just says memory full. Went to GoPro website ironically for troubleshooting and they recommend format in unit and on computer as a secondary. Sena 10c is basically a 20s right now. Speaking with Sena tech support surprised at the lack of technical solutions or options. They said try paper clip to back of unit to reset, remove sd card and reinsert and try again, and then to top it stated supplied brand new usb cable was probably bad and to try another cable. I was like really? Then the tech support sent an attached you video with an old sena product do firmware update. I was like really? AGAIN... Not even same product or software, how would that even help. Seems like tech support was hoping Id die during 20 min video on how to perform a basic update. Sad Sena.... Product is only thing keeping me onboard as service was less than par
  • Alex J
    Alex J

    hi all!

    this is my first post here ... i'm getting similar to the above problems. 

    1. turn on: "hello" ... "phone connected"

    2. press camera button: "camera on"

    3. press and hold camera button: "recording" ... "sd card full" (not 100% on that quote, she may say "memory full".

    I've tried:

    - i now the card only has about 5 gigs of stuff, but i thought there could be a count limit, so i deleted a bunch of pictures, the card has maybe 10 pics/vids, 3 gigs total. no change

    - pushed the recessed reset button. no change

    so... i'm not finished... still need to:

    - copy everything off the card and re-format it using the device itself and see if it works.

    - i have another micro SD card that I can try, so I will, but have little faith in this.

    - and that's all i got. I haven't called tech support yet.

    my big question, I've read through several threads and it seems Sena tech support doesn't reply in-line here, do they only respond over the phone? "user forums" are ok for open source stuff, but this is very black-boxed so it concerns me that they're keeping themselves out of the loop.


Please sign in to leave a comment.