Product Registration Web Page Issue



  • Sena

    Stephen, which web browser are you using in which you can only see up to 2014? Internet Explorer, Mozilla Firefox, and Google Chrome currently show that you can select 2015 from the drop down menu.

  • Stephen Ferrell
    Stephen Ferrell

    Ah, I see.  I'm using a Mozilla Firefox Nightly x64 build  I should have checked this using my other browsers to confirm the problem. I'll revert to using the stable build.  Sorry for any confusion.  I can confirm that the registration page does in fact work properly using IE.  Thanks for following up on this.



  • Jean-Yves LEMAIRE
    Jean-Yves LEMAIRE

    Hello Sena team,

    I tried twice to register my new purchase... But I got this error message:

    Deprecated: Function ereg() is deprecated in /home/ on line 26 [Check Warranty : Necessary Parameter is not checked]

    I use Chrome 64 bits, nice day, Jean-Yves

  • Wayne Claus
    Wayne Claus

    I have nearly the same issue. I can't register and I want to update the firmware ASAP.
    Deprecated: Function ereg() is deprecated in /home/ on line 26 [Purchase Date : Select Month]

  • Sena

    If you are having a problem with the Product Registration page then please clear all of  the Internet cookies on your web browser and refresh the web page. When filling out your information, make sure that you fill out all of the necessary information and select the check box at the bottom to agree to the Terms of the Product Warranty Statement.


    If you are still having problems then try a different web browser.

  • Daniel Kerr
    Daniel Kerr

    Attention Mac users!!!! I recently tried to register my 20S and it would not work using the web browser Firefox. It is up to date, but still does not work.

    I tried using my Safari web browser and for whatever reason it worked. I hope the people at Sena can fix this problem, it has been VERY inconvenient. 


Please sign in to leave a comment.