0

SOLVED!!!

NOTE: I am using Windows 10 computers, not Mac, and this procedure brought my helmet back alive, rendering it perfectly functional with the latest Firmware...

HISTORY:
I went through this once about a year ago, trying to upgrade my helmet from Firmware version 1.0 to 1.1, and I found that it hung-up at 90% like we've all found here. After trying a few different options (used a different PC, used a 2.0 USB port rather than 3.0, uninstalled and reinstalled the software - not exactly sure which option did the trick), I finally got it to work (perhaps it was a new driver?  Different order of procedures used?  No clue...). FAST FORWARD a year, and now I tried the same thing again, upgrading from 1.1 to 1.2, and the same thing happened to me once more. It froze at 90%. But THIS time, I couldn't get the helmet to respond at all. I thought I'd bricked my helmet, but that's when I started scouring the net for suggestions and solutions, and I found this thread. Though this thread helped immensely, I finally found a combination of exercises that finally got the upgrade to go through. Read on...

MY MODEL OF HELMET:
I have a BILT brand "Techno 2.0 Bluetooth" helmet, which in my opinion is the best helmet I've ever owned. When it is working, the Bluetooth connection to my phone is flawless, and it gives me so many options and abilities that it leaves me wanting for nothing at all. Not the least of which is seamless communication to my passenger's helmet (same model) for communication, and also the ability for us BOTH to listen to the music my phone is playing.

FIRST PROCEDURE PERFORMED (Do not do this at this point):
I started by going to cyclegear.com, and I downloaded their software on a computer that has never had it installed. I tried to upgrade normally, and it hung at 90%, just like before. I could have started bashing my head against the wall here, as after about a year, the same problems were still persisting with the firmware upgrade procedures hanging and not completing.  Negative memories of my earlier attempts suddenly came rushing back to me, causing quite a bit of dejection and depression.  What occurs here is that during the Firmware update, it stops at 90%, and you are forced to either disconnect the helmet, or use Task Manager to stop the application, or try to do a hard-reset by sticking a pin in the little hole, or a combination of any of the above. And then the firmware installation is terminated, and the helmet is bricked. Power button doesn't work, and only plugging the USB cable back into the PC gets it to do anything at all, which is still basically nothing. The PC simply recognizes the unit, but it's still bricked. When this procedure is performed, and the firmware update fails, the helmet has *NO* firmware installed on it at all, which negates any functionality to the helmet completely. Ok, so it still works as a HELMET, but I bought a BLUETOOTH helmet for a reason, and damned if I wasn't going to figure out how to solve this one and get my baby back to good...

WHAT I DID TO FIX THE ISSUE:
So knowing that BILT is a Cycle-Gear brand, but ALSO knowing that SENA is the manufacturer of the Bluetooth unit itself that's built into the helmet, I started searching through SENA's website for solutions. I noted that they also offer a piece of software for firmware upgrades (very similar to Cycle-Gear's software, but not exactly the same), and I also realized that SENA's software installs a slightly different version of the DRIVER that is used to recognize the helmet when connected to a PC. At this point, the wheels in my head started turning...

SECOND PROCEDURE PERFORMED (Yes, you can start following these procedures now):
On yet another completely different PC (again, which has never had any software for these upgrades installed on in whatsoever), I started with the SENA software for the firmware upgrade. At the time of this writing (4/4/18), this is the link that took me to SENA's software:

https://firmware.sena.com/senabluetoothmanager/SenaBluetoothDeviceManagerForWindows-v3.7-setup_x64.exe

I installed this, and it walked me through the process. It installed a driver, it installed the software without issue, and it prompted me through the normal processes of plugging in the helmet, and then asking me to click NEXT to proceed. Even though the PC recognized the helmet as a device, SENA's software told me that my helmet was not compatible, and didn't allow me to proceed. Fine. Now go back to cyclegear.com, and download THEIR software. Again, at the time of this writing, this is the link that I found in order to get the latest Cycle Gear firmware update software:

https://oem.sena.com/cyclegear/device_manager/CycleGearBluetoothDeviceManagerForWindows-v1.2-setup_x64.exe

So here we go...

Now install THIS software, let it install THAT driver (yes, right on top of the SENA-branded software and driver, which you should still have installed on your system), and let the software proceed normally for installation. Accept all defaults. Upon running the Cycle Gear software, it will again prompt you to plug in your helmet, and it should recognize the helmet without issue. It shows you that a Firmware Update is available, and prompts you as to whether you want to upgrade the helmet from Firmware version 0.0, up to version 1.2. Say YES.

This message (that it prompted me to upgrade from version 0.0 to version 1.2), is what proves to me that any traces of functional firmware had been wiped out completely in the earlier process. Say yes to the prompt, and it should install normally now. Your exact model of helmet may yield slightly different results, but during this upgrade, my software prompted me at about 70% to press the Center button and the + button at the same time (the combination to simply power on or off the unit), and after I did that, it recognized the command and zoomed through the remainder of the upgrade. It finished normally, and the helmet was completely back to good and all functionality was restored. And the new firmware, 1.2, was installed, completed, and functioned perfectly. I didn't even have to resync the helmet to my phone - it came back 100% and works great.

SO IN SUMMARY:
1) On a brand-new PC that has never had any traces of these softwares installed, download, install, and run the SENA branded software for firmware upgrades, linked above. It will install a driver that recognizes the helmet, but the software, for me, failed to recognize my model of helmet and failed at that point. Let it fail if it does so, and proceed to step 2.
2) Download, install, and run the CYCLE GEAR branded software for firmware upgrades, linked above. THIS software will install a driver as well. Let it do so, and accept all default settings.
3) Follow all prompts, walk through the firmware upgrade, and it should proceed to completion.

Hope this helps my fellow riders out there. Stay safe, and keep the rubber on the road.

 

0 comments

Please sign in to leave a comment.