30k firmware update, device manager won't recognise unit



  • Roger Hamilton
    Roger Hamilton

    You are not alone my friend. I'd be embarrassed to work for a company like Sena. I can't even send a ticket in to find out how to get one of ours replaced as I don't have the box so can't put the code on it, therefore can't submit the form.

    This is what happens when software people get involved in the customer experience. They just don't get it. So I'm just going to keep spreading the word so others don't make the same mistake we have. 

  • Camilla Kleindienst
    Camilla Kleindienst

    I have no other words except  - TERRIBLE

  • Patrick Moon
    Patrick Moon

    I have the same issue.  Mac OS and 30k and WIN 10 and Win 7.  Nothing works

  • Markus Rüdiger
    Markus Rüdiger

    Any news on that topic, got same issues here. 

  • Huisman Danny
    Huisman Danny

    I have exactly the same problem. Using Catalina latest version. I tried the whole morning. Changing cable, original cable, USB-Adapter, different connections, Reset, set back to factory settings. No reaction.

    Hmm, even after one month. No reaction from SENA. How the hell are they support customers. Many companies would not survive such behavior... .

    It's the first time I bought a SENA System. Before BMW and others. Never had any troubles like this.

    One unsatisfied customer will tell to many others.... its like a snowball effect. Could you afford this SENA?

    So please help and give answers to your customers who finance your salaries. Thank you!

  • Hans Jud
    Hans Jud

    I have the same problem. Win10 Pro 64. Please help !!!

  • Ric Atkinson
    Ric Atkinson

    Hi Guys,  I'm the OP and I solved this but it wasn't cheap.  I bought the wi-fi docking station and once set up it auto updated the unit.  Note however that you CANNOT use an Apple device to set up the docking station; it has to be Andriod (yeah, really).

    SENA have released a dedicated app as a work around to update the 30k (only) to the latest firmware.  I don't know if it works but you should try that before forking out £60 for the docking station.

    Hope you all get sorted.  Also hope SENA sort their lives out and put their customers first but I won't be holding my breath.....

  • Jason Bernal
    Jason Bernal

    Essay Writing Services UK is one of the finest platform which you can reduce you work plagiarism in a very legit way and get the good help from our mentors today in a very cheap rate in all around the UK

  • Jake Carter
    Jake Carter

    Get only the best essay writing services, at the most reasonable prices. Our writers will submit all the work within days and will also be available throughout the day to answer any query you might have. Stop procrastinating and hire experts for your query.

  • Zkungfui

    Same here

  • Chris

    I did a chat with sena support. They got my 50s to be recognized by device mgr by doing 2 things. 1. Plug into my windows desktop using the backside of desktops usb ports. Don’t use a hub. Use a port that is right off the motherboard I guess was the point. Don’t know what to tell you if you use a laptop. Try another port I guess. 2. In windows 10 you need to turn off the device signature requirement. Google it. I remember go to settings, update, restore, startup, then option 7 which is disable driver signature enforcement. It worked for me. There are several ways that google shows how to get to option 7. P.S. The 50s music quality is fantastic!

  • Martin Schempp
    Martin Schempp

    Chris, did you check music quality while "Bluetooth Intercom audio Multitasking" is active?
    In my case, I can hear a slight distortion in the middle and high frequencies.

  • Chris

    No I left that setting in its defualt which is off I believe. I read somewhere that if you turn that on you will loose audio quality. Even with it off, I connect to a zumo 595 and the 2nd 595 connection for garmin smartlink and my iphone 11. The only thing maybe we are missing with multitask turned off is dipping the volume with gps instructions. With it off, the music stops and resumes after the gps instructions. No biggee for me.

  • Koji Lyu
    Koji Lyu

    Hey guys, not sure if you solved your problems of Sena Device manager not recognizing your device.  I had similar problems, but solution was rather easy.  one is make sure that you are NOT using cable connecting to the PC without the wifi (cable with rectangular unit).   2.  If your unit is from Harley Davidson, than you must go to Harley Davidson device manager.  https://oem.sena.com/harley-davidson/  go there and download Harley Davidson device manager.  It should be recognize your device.  Good luck.


Please sign in to leave a comment.