Freewire wont charge - Charge light flashes blue and red rapidly


I have a Freewire that previously worked fine but recently wont seem to charge. When I plug it in to charge it either from my computer or from power supply the charge light just blinks blue and red rapidly. The unit never charges. This is a unit from 2017 so I guess it's possible the non-replaceable battery has gone bad but wow.. only three year life to this unit? For the price we pay for these three year life expectancy is not very appealing.

I have tried the fault reset and i have factory reset this unit several times but I still get the same outcome.

I am still able to connect the 12v power supply that came with it to power it on but I'd prefer that the battery charge so I don't have to use the power supply.

  1. Has anyone else had this type of problem with your Freewire before?
  2. If the Battery is bad has anyone attempted to replace it? I know the documentation says it's not replaceable but I can't believe that it's not possible. If so I'd love to get some info on that.

Thanks in advance!



Please sign in to leave a comment.