10U units don't play well with Triumph Connectivity Module.

Comments

10 comments

  • Piers Denney
    Piers Denney

    Hi All,

    I have literally spent days working on this with Sena and doing my own testing (the testing that Sena *should* have done). 

    I know know the exact problem and solution. As follows:

    If you are at v2.0.2 it will work with the Triumph Connectivity if you turn off Audio Multitasking. For some reason thats the culprit. 

    Best way is to Factory Reset the headset, then pair again with the bike, then connect to a PC/Mac and use their utility to make sure that Audio Multitasking is off.

    2
  • louisemeyers
    louisemeyers


    Wow, this is amazing. The details are explained very well. Thank you so much for this one. This is what I need right now. keep posting.

    Global News

    0
  • Piers Denney
    Piers Denney

    Update. 

    I have upgraded my helmet to latest firmware (v2.0.2) and Music is no longer audible. The bike shows music is playing and the phone confirms this. There's just no sound from the 10U. 

    Now maybe you have to have the extended settings in a specific combination, but I can't find any documentation on that.

    Ball seems to be in Sena's court to figure this out... They "broke" it.

    0
  • Piers Denney
    Piers Denney

    More Updates....

    I just backed the Arai 10U back down to firmware v1.3.2 and hey presto - Music works again.

    0
  • Gangstigen
    Gangstigen

    I follow this. Have the same problem.

    0
  • Gangstigen
    Gangstigen

    How did you restore the firmware? I can only go back to 2.0

    0
  • Sena Marketing
    Sena Marketing

    Gangstigen You can download any version of the firmware for the 10U here https://www.sena.com/product/10u/downloads and use the "Browse..." button to open the firmware file in the Firmware Update section of the Sena Device Manager. Click on the Update button at the bottom to install that firmware file on the 10U.

    0
  • Gangstigen
    Gangstigen

    Works great after that! Many thanks for update in the matter. Even adjusting volume works now. I have not tested phone yet, but assume it works as well.

    0
  • Emmanuel Fuentes
    Emmanuel Fuentes

    Piers Denney

    I went one step further and updated to 2.0.3 since those powering off issues were a little annoying.

    I did what you said and disable Audio Multitasking and sure, audio was OK but the volume control no longer works.

    • If Audio Multitasking is enabled, volumen control from the bike works but we have no audio.
    • If Audio Multitasking is disabled, volumen control from the bike doesn't work but we have audio working fine.

    I wonder if connecting the bike through "Universal Intercom" will work, haven't tried that yet.

    I hope Sena can work out this issue.

    0
  • Wayne Allen
    Wayne Allen

    So I managed to get my 2.0.3 10U working as advertised by making sure it was paired to the Triumph first, and then pair the iPhone as the second device. I read somewhere that it was the only way to get it to function with the Triumph BT... So I can control volume, skip tracks etc using the bike controls even when using Spotify on the phone.

    Took a bit of messing about to work it out...

    0

Please sign in to leave a comment.