Failed to recognize device. Cannot open USB [1][N]



  • svrider69

    Update: I was able to successfully update my device after digging up an old USB cable from an LG cell phone and trying that. So I guess my advice to anyone struggling with the same problem is try as many USB cables as you can. 

    I also gave the manager as many permissions as I could in the system preferences > security and privacy menu, although I tried many times after that without success before getting this cable to work on the first try. The only other thing I did (which I'm pretty sure I tried before) was hold the phone button for 5 sec and then hit NEXT in the device recognition step without releasing the button. 

    Pretty absurd that this is what fixed it. I guess most of the MSRP goes into manufacturing the hardware because it sure doesn't go into their programming team.

  • juanpaillet

    I tried many times with the SRL2 in a MacBook Air (Monterrey 12.4) without any positive connection, always the same, impossible to open USB [1][N]. Same computer, same SUB cable, same USB port, successful connection to Sena K30, without any problem, in the first time. I think there is a problem with SRL2 and must be solved by Sena, as soon as possible. Please contact me. Thanks

  • Jeff Hawkins
    Jeff Hawkins

    It was definitely the cable for me. I used an Apple USB-C cable (came with my iPad) and it immediately connected.

    Sena 50s

  • Thomas Lenzmeier
    Thomas Lenzmeier

    I am sure glad I found this! I had the same issue and found another USB-C cable. Unbelievable that they have us use a worthless device to update firmware.

  • Steve NGUYEN
    Steve NGUYEN

    It seems that I'm not alone.  Finally, I used a USB cable from my old Samsung Notes and it worked just fine.

  • Bart Vanderkelen
    Bart Vanderkelen

    My Sena SRL will not connect to computer. error : Failed to recognize divice. Cannot open USB. Divice Manager version 4.3.8 I use Windows 11 computer.

  • michiel nijkamp
    michiel nijkamp

    I tried the same but don’t get that number 7 ? Press the key with 7 on it? Doesn’t do anything, or is it f7? This step confuses me..

    tried it 2 times did not work

    Then did get it to do wifi update only to end with rubbish program on iphone 11 with english auto and version 1.15? Or something while i should be installing 2.21? For my sena 50 R version 2.
    Really rediciulous for such a top brand, at least in pricing.


    and spent the whole evening on it i was fuming out of my ears.

    device keeps stopping giving info on route directions unless i play music constant,seems it powers down completely after a few minutes

  • Gerald Cates
    Gerald Cates

    +1 this on my 50s and Windows 10 PC. I think it was more an issue between the cable and the PC than anything to do with the SENA unit.

  • Gerald Cates
    Gerald Cates

    If the first cable you try doesn't work try a different cable. The units are fussy about which cable they like and which they don't.

  • Bart Vanderkelen
    Bart Vanderkelen

    I know the problems with the cables. But the cables I used before where working on my Win 10 computer. Now that I have a Win 11 computer they don't do the job anymore. I tried different other ones from my Samsung phone my Samsung Tab and a new original cable that was in the box of my last SRL I bought. Nothing seems to do the job.

  • Bart Vanderkelen
    Bart Vanderkelen

    I think it has something to do with the drivers.

  • Gerald Cates
    Gerald Cates

    If you use a USB 2.0 port instead of USB 3.0, see if that helps.

  • Juha Pokki
    Juha Pokki

    For me it was not the cables, but failure to follow the instructions exactly with 10R, so in case someone is having the same, I address it here:

    it is important that the 10R is NOT powered on when you push the (-) button. Just plug the cable and start the app, push (-) for more than 5 secs and click next on the app. This solved it for me as I first believed it should be turned on in the first place... which was not the case apparently. 

  • Michael

    Sena SRL Mesh
    Device Manager install is not installing the drivers, since it's not recognizing the device when using the original cable (Wifi cable).
    Using a standard USB / USB C cable solved the issue.


  • Tom (masterX244)
    Tom (masterX244)

    THat information (WiFi-Cable not being usable for update from PC) is documented in the manual.

    Bonus details: the WiFi-cable has a small embedded Linux system sitting in the thick end which handles the updating over WiFi.

  • tioburilla


    I have just solved the issue talking with a support guy.

    In my case, I have LINKIN RIDE PARK III and I was trying to upgrade the firmware using Windows 10 and WIndows 11. I have used many different cables, but I was always getting same error: USB cant be opened.

    From support team sent me some instructions in order to change the startup seetings of the PC. Basically what I did is to allow controllers not signed. 

    The steps are:

    1. Click on Start
    2. Click on Settings
    3. Click on Update & Security
    4. Click on Recovery
    5. Find it where it says “Advanced Startup” and click Restart Now
    6. The following screen will show up:

    • Click Troubleshoot
    • Click Advanced options.
    • Click Startup Settings - note that this option may be hidden and you may have to click “more options”
    • Click Restart.
    • Press the number 7 on your keyboard to Disable driver signature enforcement.

    Once you go through the steps above stop here and try opening your Sena Partner Device Manager and connecting your device to it. your computer will restart and you will be able to fully install the software.

  • Muhammad Mubeen
    Muhammad Mubeen

    Hi Everyone,

    I had the similar problem of USB not recognized and came upon this post. Created an account just to thank all those who gave their inputs. As mentioned in this post , the adaptor they gave were not working. I used an latest type-c to type-c to update the firmware in the end.

  • michiel nijkamp
    michiel nijkamp

    Answer from sena it is mentioned in the manual.. pff well maybe but i did not find it and why don’t they include such a cable with it when you buy it? its not that sena is the cheapest brand..

  • Michael Dugan
    Michael Dugan

    I too found that once I used the USB cable that came with the headsets I was magically able to connect.  I'm not sure what's special about the cable they ship with the headsets, but I tried at least five others, many used for data connections, and they didn't work.  Very interesting.. 

  • Kam10250

    Keep your Sena OFF, and it will work.  Someone posted a critical note that you MUST follow instructions.  For Sena 20 and many other mothers, you must NOT turn  your Sena device ON.  That solved my problem.  Kind of counterintuitive.  But, Sena wants you to keep power OFF. 

  • Madhur Bhati
    Madhur Bhati

    It was a cable error for me, just changed the cable (used data cable for 1 plus, you may use any data cable). It should work.

  • Steven Levchenko
    Steven Levchenko

    Confirmed Fix for Me

    Go find another USB cable. Preferably a nice thick one. The one that came with the Sena's doesn't work (2019 M1, non Mesh bluetooth only, powered off).


    • Windows 11 PC #1: multiple ports, bcdedit trick, rebooting, BIOS settings
    • Windows 11 PC #2: multiple ports, until I realized it's just not showing up in the Device Manager under "USB Devices" - if the PC won't see it, the update manager won't see it.

    If your PC does see it, but has a problem with it, then maybe that bcdedit trick would be where I would go.

    For the M1 that I have, powered off is fine. The act of plugging the USB cable in while the helmet is on will power it off automatically anyways.

  • B Ward
    B Ward

    Yeah, the cable they supplied is junk. Used my phone's cable and it worked. 

  • Anton

    Provide us with the functional USB, Its so disappointing 

  • Gunnar

    I tried multiple different cables.  All are known to work (eg., USB-C Apple, USB-C camera for transferring images, USB-A>C supplied with helmet). No luck. I doubt it's the cable because macOS properly recognizes the device, i.e. I can see it in macOS following instructions provided here.

  • Ad van Vugt
    Ad van Vugt

    Ik heb het zelfde probleem met de Harley Outrush-R helm ,op 3 pc's geprobeerd (2xMac) 1x windows10 krijg steeds de melding herkennen usb kan niet openen.

    geprobeerd met de bijgeleverde kabel en een apple kabel (beiden laden wel op en worden in windows herkent maar kom niet verder dan dat.


Please sign in to leave a comment.