MESH Stoped working and not uble to upgrade framework.



  • josh barricklow
    josh barricklow

    exact same thing happened to 2 out of 4 of my Sena 30ks!  need some sort of help.  the headsets charge fine, turn on, and bluetooth and intercom work - mesh completely not working and unable to update.  we only use MESH so that makes both headsets unusable to me. 

  • Leland Parkinson
    Leland Parkinson

    Same thing to me as well. Right after I tried updating my 30k reaches 20% failed  cannot get status {6} then when I try to restore it reaches 20% and says cannot get status {7} mesh comes on but not open mesh and also the radio is not working now . 

  • Leland Parkinson
    Leland Parkinson

    However my wife's 30k updated fine. No issues.

  • Sylvain Bertthelot
    Sylvain Bertthelot

    Same problem here to stop at 20% with cannot get status. This is my second 30k


  • Marshall Gardner
    Marshall Gardner

    I have the same problem, basket random  hope some one can explan more detail. 

  • Tann Tanawut
    Tann Tanawut

    I have the same issue on my 30K. Anyone solved this issue? Please advise. Thanks.

  • Andi

    Same problem. I have 6 of them and 4 of them are working fine but 2 can't connect to Mesh. I noticed when you turn on Mesh on those two it doesn't say the complete prompt message as it does on the other 4 that work fine.
    The two versions of prompt message are:
    - "Mesh Intercom On. Open Mesh. Channel 1." (on the ones that work fine).
    - "Mesh Intercom On." (on the ones that don't connect to Mesh).

    I believe that has something to do with the problem, as well as not being able to update the firmware and stopping at 20% saying Cannot get status (7).
    The thing is I can't find anywhere online how to get them back to hearing the complete prompt message when turning on Mesh.

    SENA Help Desk, please read this and give us all a solution.

  • kishan meena
    kishan meena

    Andi, Can you please check and tell me if the 2 SENA's are bit older then the 4 which are working. Someone told that it's SENA's software issue which hit early manufactured SENAs. Something like this happned with us too, 2 of 3 are not working but 1 got updated and it was 9 months new then other 2 SENA 30K.


Please sign in to leave a comment.