50C firmware update failed


8 comentarios

  • Bananaferret

    I'm having the exact same issue. Did you manage to find a fix? Mine is new out of the box so this is disappointing

  • Cowboy Comboy
    Cowboy Comboy

    Mine upgraded successfuly few days after posting the issue here. Did nothing special, wish you luck :)

  • Terry Ryan
    Terry Ryan

    mine is new as well...firmware upgrade will not update.


  • nathan weber
    nathan weber

    I bought 2 brand new Sena 50C, both were in need of update. i updated the first one with no issues using wifi adapter but second kept failing at 2nd step at 30%, tried updating with computer and would not take either, kept saying it updated but software still showed out of date. Contacted Sena and was told that is it sounded like a faulty unit and to replace it. Took back to store and exchanged with another new unit which also failed update both wifi and on computer. Finally after attempting update several times, found the solution for my case. With 50 C unit it needs a memory card installed in unit and need to format it using sena keys with holding down camera button until you hear format promt then hit confirm key by pushing side rotating button. Now it should be ready for firmware update, I did not try wifi cable I used computer to update which I had to use my go pro type c usb cable to attach to computer since wifi cable will not connect 50c to computer, computer will not recognize it. Updated using sena utility on computer and now took update. I wish sena would put in instructions to install sd card and format to perform update, all utility says it to have sd card installed and Sena turned off. It did not work until I formatted sd card. 

  • Tom (masterX244)
    Tom (masterX244)

    nathan weber the wifi cable itself has a small linux-"computer" at the thick end of the cable. only power is taken from the USB-A end

  • Shalan Prithviraj
    Shalan Prithviraj

    Created a login just to say thank you to the original poster. Pressing and holding the camera button on my 50c for 5 seconds did not help for me. I had to download the 'Sena Camera' app and connect to the headset via bluetooth. The 'Sena Camera' app then asks you to press the camera button once which starts the camera and also turns on the wifi on the headset.   You then connect via wifi from your phone or device to the headset and use the 'Sena Camera' app to format the sd card.    Very confusing - I suspect the 'Sena Camera' app is designed to communicate with the headset only via wifi -   Thanks again 

  • Jinu Oonnoonny
    Jinu Oonnoonny

    nathan weber was struggling up until i saw your post. put the sd card and the firmware update went through even without formatting the SD card

  • Federico Berton
    Federico Berton

    My experience is that I had exactly the same issue and would not pass stage 2. After reading and understanding nathan webber post, I did performed a card format but it still would not update. I then tried another card, format it and it still did not update. I tried a third card (I have six) and it finally worked! In order to update, the Sena 50C seems card format dependant. Please try to format different cards if you have that possibility. Again press camera button once to switch on camera and then hold the camera button until Format prompt is spoken and press phone button to format. switch off and try updating. Failing that, do try another formatted card


Iniciar sesión para dejar un comentario.