50s firmware not updating over wifi or computer

Have a 2 pack of 50s units.  One updated just fine, one is giving me a very hard time.  Tried a factory reset, bluetooth connects fine with the new Sena Motorcycle app but it immediately says to plug via wifi adapter or computer for a firmware update to the 50s. 

wifi adapter is connected to my network, but it does not begin to update the 50s and I've let it sit for a good hour and still no update starting.  The wifi adapter has been updated to the most recent software (ver 1.12) and has a solid blue light indicating it's connected to my network.  The app also sees the wifi adapter and confirms it has the updated software.  

I also tried to use the PC app to update the 50s but the computer does not recognize the 50s is plugged in.  I tried restarting the computer, uninstalling and reinstalling the app.  I tried different USB-C cables, and verified the cable works for data with another device.  Verified the computer is recognizing new USB-C devices being plugged in.

Any suggestions on what to try next?

7 comentarios

Iniciar sesión para dejar un comentario.