Sena 30k V2.3.1 update + Mesh intercom not working


10 comentarios

  • Amr Khaddam
    Amr Khaddam

    i have the same issue after the latest update. mesh intercom is working but can't connect to any other sena users, i can't even change the channel from both app and device

  • Tom (masterX244)
    Tom (masterX244)

    Try to downgrade to a older Firmware (there is a mirror of all versions over at )

  • Stratos

    Hello! Thanks for your replies.

    Tom, i tried every version and still i got the same issue. 

    On 20% percent i get the message "Failed to update Firmware. Cannot get status {7}"

    1) I have windows 10 and followed the Fix for Windows 10 that sena has here.

    2) Also, my windows are original and up to date.

    3) I tried to use different cables, ports and even PCs-Laptops

    4) I run the programm compatible with Windows 7 and administrator, as i read some fixes that worked this way.

    5) I tried both version of Sena bluetooth manager, V 4.3.8 - 4.4.2.

    6) I did Factory reset on both Devices.

    7) Check picture clean on Imgur :

    8) I also updated my Sena SMH5 without any problems and it was done right away.

  • arjunbr

    Same issue I am not able to use mesh at all for 30K, also not able to restore to any firmware too

  • Stratos

    Guys did anyone manage to do something?

  • Stratos

    Which currentt versions you have installed now?
    Mine is V2.3.1

  • Brianbrannon

    Same problem same terrible sena customer service

  • Richard Tilton
    Richard Tilton

    I have same version (cannot change it) and no Mesh, only some bluetooth and at 20% update mine says cannot get status (7)

    With this a common issue, someone at Sena should be smart enough to resolve this and help out on THEIR OWN SITE, rather than ignore us with problems !

  • Bob Smith
    Bob Smith

    I have the same problem. Tried with several computers (Windows 11, 10, 7) with the exact same result. I am so tired of this product. I spent and made my friends spend a lot of money only to have problems. Was working ok when we were all on 20s then I was the first one to upgrade to the 30k. What a mistake! Absolute piece of crap! Thank you Sena!

  • Marcanthonydorn

    I had the same Problem one one of my 30k´s.


    But i managed to fix it, i took it apart and applied slight presure on the mesh communication chip while turnig mesh on, and it worked.

    So i resoldered the area that i supplied pressure to and now its working again without any problems.

    on my device it was a bad solder joint of the chip that caused the issue.


Iniciar sesión para dejar un comentario.