90% Firmware Update Hang/Freeze FIX

After a few hours scouring the Internet on complaints about upgrading the Sena firmware hangs at 90%, I went into troubleshooting mode and found the fix for everyone. No need to bash Sena or complain about sending back for a long RMA process. Tip to remember: I learned a long time ago, the older tech products run into issues when connecting a 2.0 device/cable into a USB 3.0 port. This worked for update firmware on my SMH10R to v5.1.2.

90% HANG PROBLEM SOLVED: Must use a USB 2.0 Port (NOT 3.0) on your computer with original USB cable. After a few seconds at 90%, you'll get a yellow pop-up screen instructing to hold center and + buttons until pop-up disappears. You do, it does, and completes to 100%.

Setup: Windows 10, x64, original USB 2.0 cable, USB 2.0 Port, run as administrator. I did a fresh uninstall/re-install of the program once I changed to a 2.0 Port. If you hang again during the process, simply unplug and force close the Sena program. But the key here is the yellow pop-up screen you didn't get before after being on 90%. This will appear after about 30 seconds at 90%, so no need to get angry again.

Drop a comment if this worked for you as well - you owe me a beer if it did - hope to see you around the Rockies.


~Mike F.

Colorado Springs, CO

12 comentarios

Iniciar sesión para dejar un comentario.