Failed to recognize device. Cannot open USB [1][N]

I recently purchased a 10C Pro and am unable to update the firmware. I have downloaded the SENA device manager a couple times now, yet I keep receiving the error message "Failed to recognize device. Cannot open USB [1][N]" after following the steps in the manager (power off, plug in, hold phone button for 5 secs, click NEXT). I am on a MacBook Pro 2015 running OS Big Sur 11.4. 

Things I have tried:

- formatted the 64GB SDHC card using the 10C Pro

- different USB ports

- another USB cable I had lying around (I've been using what was supplied)

- Fault reset

- Tried to update on a 2012 MacBook Pro with the same results

Nothing seems to work and it's super frustrating. I've already submitted a ticket which was an exercise in patience, but I thought I'd see if anyone here has ever solved this apparently common issue. I've read you need to use USB 2.0 but I don't have any computers less than 3.0 right now. The device seems to work OK after testing it out on my helmet but I'd really like to have the latest firmware and be able to keep updating it after paying so much money for this thing.

15 comentarios

Iniciar sesión para dejar un comentario.