M1EVO Helmets not recognized on computer

I am sick and tired of trying to get my helmets set up and seen by my pc. I have had multiple replies from Sena saying to do this and do that and nothing has worked so far. What is the issue? It is simple with any other device but Sena has a screwed up problem. I have tried install on 2 computers and nada. I am ready to send 2 helmets back. My computer won't recognize the things no matter what I do. Reinstall program, use the right USB port, etc. This should be a damn no brainer. Plug in device...it is seen by the computer...install software and it sees device and like everything else I install, no issues. I have $400 invested and I feel like I am dealing with a third rate company. I have had Sena motorcycle voice systems and they were extremely easy...what the heck happened? I am struggling here and not getting anywhere. Can you tell I am frustrated? I guess I could live forever with the original firmware....but not happy about it. Maybe it is me,,,,

0 comentarios

Iniciar sesión para dejar un comentario.