4

Ongoing Issues with 20s and NO response from Tech Support!

After much research, my husband and I purchased a dual pack of the new 20s headsets.  We both work in IT, so we are at least basically tech-savvy.  The first pair worked...for a while.  Then, suddenly, we would lose connectivity over the intercom feature.  There would be no warning, just one of us would ask a question to the other...and no response.  We'd re-pair the headsets and this would fix the problem, but only briefly and then again we'd drop off.  This was riding right next to each other and appeared to be worse in town versus on the highway.  Finally, we returned that set of headsets after mine would no longer accept any commands or even turn off, just constantly beeping and saying "Group Intercom Failed."  We could get no response from multiple attempts to contact Sena's tech support, so we returned them to the store we purchased them at and got a replacement pack.

So, now we have 2 new 20s headsets.  We paired them with our phones and each other.  Now we can either listen to music on them...or use the intercom feature, but not both at the same time or we experience a similar issue with the intercom pairing becoming unreliable.  Again, attempts to contact Sena's tech support, who when you do reach them seem to have little to no training, are in vain.  We're just about ready to return these for a refund and find something cheaper that at least has a reliable intercom feature.  We've never been able to use the advanced features of these headsets, the ones we paid a lot of money to get.

I'm frustrated and extremely disappointed with the support from this company.  Does anyone actually get help from their tech support?

4 commenti

Accedi per aggiungere un commento.