device manager is not shown Sena 10c

This is already the 4th request. 
I bought my password 10c in Revzilla store. 
After the penultimate update available in sena.com site. my Sena 10C is no longer recognized on any computer. I already test on five computers with different operating systems. Before the upgrade was not recognized now. 
In device manager is not shown Sena 10c .. 
I await a solution. 
I live in Brazil and I am Store customer Revzilla.

thank you 


Your request (#96524) has been received, and is being reviewed by our support staff. 
To review the status of the request and add additional comments, follow the link below: 

Audiovideo, Jan 7, 2:23 AM: 
This is the 3rd time I get the same answer. 
I tried it on three computers and all to no avail. 
I tried it on Windos XP, Windows 8 and Windows 10. 
The Sena 10 C is not recognized. 
Popr please help me! 
Old answers: 
Joseph Heindrich Awayan™, Jan 4, 9:36 AM: 
Hi Celso, 
Thank you for contacting Sena Support. 
Here is a step by step tutorial video made by SENA on how to by-pass the device recognition issue: (please try using a Windows based PC as this video is shown) 
https://www.youtube.com/watch?v=TRBXzRfODtE PC 
https://www.youtube.com/watch?v=_UAduPfn57c Mac 
video may show a different device but the steps should still be applicable for your device. 
It will help guide and walk you through the process of updating it and by-passing the device recognition. 
Hope this helps. 
Sena Support Team 
Audiovideo, December 31, 2015, 3:04 AM: 
I tried it on Windows XP and Windows 8. There the device is recognized. I followed the video with step by step instructions but did not succeed. 
Please help me! 
Sena 10C Device recognition failure - Unable to open USB 

1 commento

Il post è chiuso ai commenti.