SRL - Cannot Update Firmware, USB not recognized....

Commenti

11 commenti

  • Mervin Van der Spuy
    Mervin Van der Spuy

    I just bought the 30k this week and have the exact same problem!

    0
  • rob.gronewold
    rob.gronewold

    Yep, that seems to be a pretty common issue these days.  I've tried multiple computers, multiple USB cables, have uninstalled and reinstalled the SENA app and drivers...same result, still get the error message.

    0
  • William Gordon
    William Gordon

    Same here, just bought the 20s EVO, it will not connect to the server, if the firmware is installed manually from the sena archive then the device says the firmwareis corrupt, and the device mananger doesn't recognise the s20. This is a terrible piece of kit and there is no support from sena. Making sure that my friends do not buy a sena.

    1
  • Marcin Waściński
    Marcin Waściński

    When installing on a computer with Windows system, a window for installing additional drivers opens in the meantime. Whether you accepted it or rejected it. Maybe you are making a mistake here and the problem ??????

    Regards

    Marcin

    0
  • Art A.
    Art A.

    Marcin, no that is not the problem, its not a pop-up I'm missing. The problem is the same whether I use a Mac or Windows based laptop....

    Follow up:   A GREAT reason to buy from a "brick and mortar".  I called the place I bought it from and talked to one of their employees very familiar with SENA products.  He pulled a unit off the shelf and walked through the update process while I was on the phone.  His worked.   He told me to please  bring in my unit and he'd take a look.  He said he'd hold the unit he just updated to switch out with mine should mine be defective.

    I drove over and he plugged my unit into the same computer he just used to update the new unit.  Sure enough mine was BROKEN!  He couldn't get his laptop to recognize my SENA unit.   He plugged in the good one again and it was recognized.  

    He then swapped units for me.  I now have a working unit.  But it does anger me that there are a fair number of these units that are being delivered defective.

    The Gent told me in the short time his shop has been carrying the SRL he's seen more of the SRLs returned/brought back because of problems.

    1
  • Marcin Waściński
    Marcin Waściński

    You're right. I already have the intercom exchanged for a new exchange procedure operating in Poland, which is terrible. Shops are in the ass of the customer, they sell the goods and you have to claim your rights yourself. It's good that the set sells Shoei Polska and they have a door to door service. And so all the "fun" lasted over a month and the intercom functioned properly from the first launch. Too many of these sells on the market ....

     

    1
  • dan
    dan

    After spending an hour with "Tech Support" and doing the exact same thing time and time again (the definition of insane) and SENA was expecting new result, SENA said I should return the device for a replacement.  Fine and dandy.  New unit does the exact thing.  20S connects just fine, SRL does not. Obviously an issue with the device driver that SENA should address.

    0
  • PinotGrigio
    PinotGrigio

    I have just installed the latest firmware on Win10 64bit. No problem. In any case, it is important to use the right cable. I use the original cable with the right-angle plug.

     
    Kaspersky Password Manager
    Erstellen Sie ein sicheres Kennwort für Ihr Konto.
    ERSTELLEN
    Nicht mehr anzeigen
     
    Kaspersky Password Manager
    Erstellen Sie ein sicheres Kennwort für Ihr Konto.
    ERSTELLEN
    Nicht mehr anzeigen
    1
  • Ian Neale
    Ian Neale

    I fought with Sena on my last 30k, and their answer was to disable the Windows 10 requirement to run only signed drivers, i.e. reduce the security on my computer to run their botched software product. 

    PinotGrigio, I saw your post, said, "there's no way that should make a difference" and went to grab my stock cable. Changing the cable worked, my 30k is updated. Go figure my other cable must have been a cheapy for power and not data. Thanks!

    0
  • PinotGrigio
    PinotGrigio

    Ian Neale, I'm glad that it worked out for you :-)

    0
  • Graham Wilson
    Graham Wilson

    Same problem. The fix for me was to use the supplied usb cable, i.e. the one with a right-angle connector.

    0

Accedi per aggiungere un commento.