Sena 10C Pro - Cannot connect to WiFi with Sena Camera App


5 commenti

  • beans

    Try 1234567890 as the password

  • Rod Halverson
    Rod Halverson

    I was looking for the correct Sena 10C evo wifi password. 

    Long story short it is sena0000


  • Christeena Knowles
    Christeena Knowles

    I struggle 90% of the time to get the camera connected to my Samsung Note 8. So far the app works fine when I can get it to connect. By now I had hoped this would be a tad easier but I an new to Sena products and will get out on the bike and do some recording before I make a solid opinion. 

  • Graham

    Hi all,

    Have a solution from the support desk via the SENA website. I could not connect to a Galaxy A5 and my work computer was blocking download of the firmware. Martha at support was very helpful.

    Hi Graham,

    Thank you for contacting Sena Tech Support.
    I'm sorry to hear about the issue with your 10C Pro.

    Unfortunately, the apps cannot do a firmware update on the 10cPro itself. If you have windows 7, 8, 10, in 64 bit, I've attached the program so you can download this from your email directly, and perhaps your office won't block it.
    Once installed:
    1. Turn off the 10cPro (should have sd card up to 64GB) and plug it into your pc using the original USB cable.
    2. Follow the instruction until you will reach the Device recognition page. Make sure to push the phone button for 10 seconds before you click next (Note 10C should be off at this point). It will prompt you with the latest firmware when the device is recognized.

    Once the update is done, proceed with the Factory reset (attached) while the unit is on. 
    Uninstall the Sena camera app, reboot/restart the Galaxy A5, reinstall the Sena camera app.
    Put the phone into airplane mode, enable wifi only, and try connecting back the 10cPro. You can follow the steps from this link 
    If still the same, please try a different phone for further isolation.

    Tech Support Dept.

    10C Pro Buttons.jpg
    10c Pro Factory Reset.jpg

  • Jeff Young
    Jeff Young

    Harley stamped 50c makes the Wi-Fi connections but will not connect to the app. This is the second headset due to the same issue. The first one worked for almost a year. This one here has been paired through the Wi-Fi connection 3 times. Any suggestions would be appreciated.


Accedi per aggiungere un commento.