10c pro failed to update firmware


2 commenti

  • Darryl Wong
    Darryl Wong

    Kevin have you tried a smaller SD card, a different cable and a different computer. I think I have had this issue on different Sena's and usually one of those will work.



  • Keith Irving
    Keith Irving

    I have struggled for ages to get my 10C Pro firmware updated.  The problem would seem to be my computer is too up to date.  I have both USB 2.0 and 3.0 and, despite numerous internet claims that the Sena Bluetooth manager will only work on USB 2.0, it seems that it is even more picky than that.  I used an old computer with old USB 2.0 ports and it worked first time perfectly.  With my new machine it refused to work throwing up error messages that didnt really make sense "Not the recognised device", "Unable to get status [1][0]" and so on.  Even the Sena support technicians werent any help.  I got lots of suggestions, but no real help.  My advise to anyone strugling with a firmware upgrade to a Sena 10C Pro using the Sena Bluteooth manager is to try to get an older version of the USB 2.0 ports.  Then complain bitterly to Sena that they should do a bit more software testing, because quite obviously, they are not interested in correcting this problem.  If it leads to lost sales in the future, and I am seriously thinking of alternatives, then maybe they'll do something!


Accedi per aggiungere un commento.