50s Wifi adapter can't find home wifi network


35 commenti

  • mark

    Yeah, whoever Sena subcontracts software development to apparently never learned how to program. Or failed all the classes on how to test stuff :).

    FWIW -- and it's been a long time since I had your experience, so my suggestion may be wrong -- I think I solved a similar problem by doing the >>first<< firmware upgrade by attaching the unit to my desktop via a USB cable.

    The earliest versions of Sena's software/firmware couldn't make/sustain wifi connections so updates to fix the problem couldn't be applied via wifi. Hence the need to do a direct cable connection.

    Good luck!!

  • Jeffrey Morrison
    Jeffrey Morrison

    I had similar issues with the USB WiFi.  My problem turned out to be that I have 2 Wi-Fi networks in my house, and the USB updater was trying to use the secondary network.  It needs to connect the primary network (the one from your internet service provider). 

    Background: I have a Verizon Fios router that I have to use for my cable television boxes to work.  I also have the Google Nest mesh routers to get Wi-Fi coverage around my house.  Turns out that the mesh network in fact creates its own sub-net (family of IP addresses) that are different from the Fios router network.  This creates what is referred to as the double-NAN problem.  If the Sena Wi-Fi adapter connects to the secondary network (the Google in my case) it doesn't see the Domain Name Server (DNS) provided thru the Fios router, which tells it how find the Sena server and/or the Sena server can't reach thru the networks to talk to the Sena update adapter. 

    If this sounds like your network, the solution is to make sure the Sena adapter connects to the primary wireless/router.  The easiest way to do this is to temporarily turn off the secondary network (un- plug the power).  Then, configure the Sena adapter to connect to the primary wireless network / router.  Verify the Sena adapter is working, and then turn your secondary network back on.  From that point forward, the Sena should stay connected to the primary network and keep working.  

    Hope this helps.  Very FRUSTRATING - Sena support had no clues.  The only reason I figured it out was because I couldn't figure out why some computers could see my network printer, and others couldn't.  When I searched my symptoms, the Google Mesh site pointed tot he double NAN.  When then realized it was my older devices (still connected to the Fios router) that couldn't see the printer (on the Google mesh network).  It occurred to me that I had put the Sena on the mesh network so it would work from my garage. 

  • timothyferriss

    Check to see if the frequency and channel your router is utilizing are compatible with the WiFi adaptor you are My Singing Monsters using. While newer routers might run at 5 GHz, some older adapters might only handle 2.4 GHz. Verify that your adapter is compatible with the frequency that your router uses.

  • Johan Kurt Silversjö
    Johan Kurt Silversjö

    Holly shit, I thought Sena was a quality brand but Sena 50R is a piece of shit! and it is supposed to be their flagship model?!?!?
    I have tried atleast 10 Hrs to uppdate this piece of shit and I am a computer technician since 40 years. The fucking Wifi adapter do not work-have resetted it 100's of times, sometimes I can connect to it but it never works anyways, the shitty Telephone software do not work as supposed either and have different name now compared to the manual, Drivers for PC do not work. Fuck you Sena!.You will not fool me buy this shit again.  

  • Ron Redmond
    Ron Redmond

    Return it


Accedi per aggiungere un commento.