0

Pairing lost

I have had a 20S for a couple of years and had no problems, but now it cannot maintain pairing with the iPhone SE.

Last night I tried again from the beginning, cleared ALL Bluetooth pairings from the 20S and also deleted that pairing from the iPhone SE. I then successfully paired the 2 devices and all looked OK, so I switched off intending to use it today.

This morning, iPhone is on, turned on the 20S which said "Hello" (or whatever it says) and then nothing. No indication that it was connected to the iPhone. So I checked the iPhone and although the 20S pairing I created last night is there, it just displays 'not connected'.

This is actually just a repeat of the last few times I've tried to use it. I've updated the firmware, I've cleared pairings, I've done a fault reset and set it back to it's factory settings, but the result is always the same. It will pair that first time, but never actually connect again.

So, currently it's basically useless. Anyone (especially Sena technical bods) any suggestions?

0 comments

Please sign in to leave a comment.