Once Again, Failure

The only thing I've ever found that works correctly, sometimes, on my Sena Evo 20S is the voice link to my phone. Which I can only get to work by pressing one of the buttons, because the voice control feature is junk. Like almost everything else with the product.

Today I extended that failure experience to a new level: I tried to upgrade the firmware, based on all the nags I'm getting from my iPhone when I run the Sena phone app. 

Only I can't. Because after first upgrading the Windows Sena Bluetooth Device Manager app, it now fails before it gets to the "recognize device" step. With the amazingly helpful error message "Incorrect parameter".

I'll tell you what's incorrect -- every single programmer employed by Sena's understanding of programming and quality control.

How do I get past this stupid error so I can upgrade the firmware. Which, who knows, may actually implement some of the functionality Sena has advertised the Evo 20S has had for years...


Please sign in to leave a comment.