SRL-01 Dead After Firmware Update

I have posted here last year under Boo Rules where I described my saga with the SRL unit for Shoei's Neo2 helmet.  Quick recap: I purchased a SRL in May 2018 from Motocard in Spain (I live in NYC/USA) as the unit was not available in the United States and I had an upcoming trip at the end of May.  First unit the mic did not work and the unit wouldn't stay connected with the my iPhone.  Unit came with firmware 1.0.2 and I updated to 1.0.3 but it still did not work.  Motocard had the unit picked up and replaced within a week (great customer service!).

The second unit came with 1.0.3 already installed and it worked fine throughout the riding season here.  Although firmware updates followed I was too afraid to tinker with my unit since it was working (reading the other horror stories added to this fear).

Fast forward to now, call it a lapse in judgement or a weak moment of too much confidence, I decided to update my firmware to the most current - BIG MISTAKE.  FYI, before updating I tested my unit to make sure it was working properly (made/received phone calls, played music and paired with the RC-4 remote)...all worked fine.  I performed the upgrade through the Sena Device Manager and now when I try to turn on the unit I get the usual "Preparing Headset", the blue light blinks twice then goes out...the unit shuts off.  I tried several times and that is as far as it goes.  I cannot get past this point.  

I restored the firmware to 1.0.3, even restored back to 1.0.1 then each in succession to 1.0.3 but the same thing as stated above.  I tried to quickly reset with the while it was on but nothing it just keeps turning off after powering up.  I then checked my phone and see it actually connects to my my phone but disconnects as it shuts itself down.

I have written to Sena and based on what I have read in these forums I wonder if they will even respond.  

Has anyone experienced anything like this? Is there a fix that perhaps I am missing?


Please sign in to leave a comment.