2

Sena 10c Pro - "Failed to update firmware. SD card not recognized" SOLUTION

I just spend 4 hours trying to update my new Sena 10c Pro and finally solved the issue. I wanted to share this in case anyone else has this problem.

When downloading the Sena Utility software I noticed the program would not connect to the server to automatically download the newest firmware. When manually downloading and installing it, the update would fail at 28% and throw an error saying "Failed to update firmware. SD card not recognized". I was using a Samsung EVO 64GB class10/U3 SD card.

THE SOLUTION:

My desktop PC was too new. It only had USB 3 ports and modern hardware.

I first formatted the SD card while it was inside the 10c Pro. The way to do this is:

1) Have headphones connected

2) Turn on 10c Pro

3) Click camera button once (big button on the top) Then click again and hold for 8 seconds until you hear it say "Camera Setup"

4) Rotate the jog wheel COUNTER-clockwise one click until it says "Format SD Card"

5) Click the phone button (button on the side) to initiate the format.

NEXT:

Once the SD Card is formatted, find a laptop/PC that has USB 2.0 ports. Install the Sena Update software to that computer. Now connect the Sena 10c Pro to one of the USB ports in that computer and follow the process in the software instructions.

Everything finally worked after formatting the card and running the update on an OLDER computer with USB 2.0 ports.

10 comments

Please sign in to leave a comment.