Failed to Update Firmware. Cannot get status

Comments

12 comments

  • Kevin Vogt
    Kevin Vogt

    Same here

    thanks

    1
  • BD
    BD

    does not work for me :(

    1
  • Scott Raines
    Scott Raines

    Well,

     My wife and I are both new to this Sena stuff. We have a pair of 1 month old (3/31/23) Sena 50S units and while they seem to work as they're supposed to while connected to our '18 Honda Goldwing Tour DCT Airbag, trying to get them to connect to either my 10 month old Windows 11 Laptop or, my wifes 2 year old desk top via either the Wi-fi USB cord that was supplied with the headsets or another USB cord, doesn't work. Neither computer will recognize either headset. 

     Is this what we paid over $600 for? Even though the box for the dual pack headsets states they are version 2.1.1 in firmware, I'd like to see that on any computer to confirm. And, not only that but, if there's a new version of firmware in the near future, how am I or we to actually convey that new firmware to the headsets if no computer recognizes them? 

    Scott

    1
  • Christopher Guilbaud-Mc Harg
    Christopher Guilbaud-Mc Harg

    Same here. Tried pretty much everything.

    For the price it’s frustrating. 

    1
  • Rick Kaczerowski
    Rick Kaczerowski

    This did not work for me either...at first.  Trying to upgrade my SRL2 to v 1.0.8 from v 1.0.  I've tried multiple known working USB 3.0 and 2.0 ports on my PC case (connected to the motherboard via a cable) and multiple known working USB cables with no luck.

    Then I used a USB 2.0 port on the back of my PC, which is part of the motherboard.  It finally worked and updated the firmware!

    1
  • Duxrus
    Duxrus

    Hey SENA tech staff do you even read the comments and help your customers?

    0
  • Ilan Tsanany
    Ilan Tsanany

    same here, very frustrating!!! Sena! help please!!!

    1
  • Rod Duggan
    Rod Duggan

    I could not get it to work, then I decided to try every USB port on my PC.  Suddenly one of them worked and the updates are in progress.  I suspected a Comm error as the moment I unplugged the Sena 20S evo it would pop up as recognized.  I have been down this path on other devices.  

    1
  • Simone Rescio
    Simone Rescio

    Well here I am too, just unpacked it from Amazon, shocked I even need a desktop app to perform a wire updated, is this 2023 where every actually smart IoT device can ben updated over wireless? not for this?

    Then attempt the update from my macbook air (which does not have any USB port only USB-C), and here I get this error everyone was having for 2 years, I guess its going back tomorrow with a 1 star review.

    0
  • Joe
    Joe

    0
  • BD
    BD

    Quite absurd. But device works still fine without update…

    0
  • Asbath Chowdhury
    Asbath Chowdhury

    Hi there,

    I had a similar issue and then had to connect to a USB port 2 and then it upgraded fine. 

    Is there an expected eta for when this will get resolved?

    0

Please sign in to leave a comment.