20s Evo completely dead

I have had Sena's for numbers of years.  I was riding with my Sena 20s Evo, talking with a fellow rider and it just died.  It was only 7 months old, it had replaced, under warranty, an older 20s that had a problem as well.  So I called Sena Help.  After several days of back and forth with the help desk, they told me it was no longer covered under warranty.  I guess because it was an extension of the previous older 20s that was covered.

I got a 20s that no longer worked, from another rider and replaced the battery.  It is what I am using now.  With nothing to lose, I took the Evo apart and replaced the battery.  It will still not turn on when I press the phone and jog button.  It will charge on the charger (blue light) and will connect to the computer for firmware updates and changing the settings.  But it will not turn on at all, no lights. I have done the manual reset which did nothing.

I'm not really happy with the quality and support.  Any other options other than to use this 20s Evo as a paper weight?  

ticket #345534



Please sign in to leave a comment.