Windows 10 and MacOS 10.14.4 Do Not Recognize 30K At All



  • Hyper Pete
    Hyper Pete


  • luigi7317

    The problem is common to many Sena intercoms!

    The drivers are not signed, by default Windows therefore prohibits their use => the intercom cannot therefore be detected!

    The only way is to configure Windows to use unsigned drivers ...

    The operations are detailed here :

    It's in French, but at worst Google Translate is your friend ... :-)

  • Ilarson007

    Hi. That is not the issue. There is a hardware problem with the 30K unit. It is not even recognized my any PC I tried when I plugged it in. I gave up on trying to update it. The USB port is bricked as far as I'm concerned.

  • Ilarson007

    To clarify, I tried the unsigned driver thing on 2 or three different computers. Same result, nothing shows up or is recognized when I plugged in the unit.

  • Steve Binckes
    Steve Binckes

    I updated my 50s from version 1.0.6 to 1.0.7 when I first got it but now it is doing what your 30K is. I have tried window 7 and 10 with old versions of the software and the latest but when I hit the next button it says device not recognised and something about the USB?

    Weird how it did work once but now doesn't and the little wireless charging dongle that supposed to update the 50s is totally useless and has never worked!

  • luigi7317

    Hi !

    This is the fault of unsigned drivers...

    "How to" is here :

    This forum is in French... If French isn't your cup of tea, use Google Tranlate...


  • Pierre Savignac
    Pierre Savignac

    Hello everybody, you'll thank me later !


    On my side, I found what the problem was !

    It's the USB connector on the unit itself ! The connector after many charging cycle become loose and the contact are not tight enough anymore.

    I took the unit completely apart to check if any of the solder on the board were broken or bad but they were all perfect.

    I then squeeze the connector a little bit to make it more tight and reassemble everything.  Voilà it started working perfectly and I was able to update the firmware again.

    I believe that if you go in between the connector and the casing and apply a small pressure of the USB connector, you could do the same job !   But be careful not to break anything !



    I know, you're welcome ! :-)



Please sign in to leave a comment.