20S Firmware Update and Other Questions

Hi all, figured I'd post here before attempting to contact Sena early next week. 

I have a 20S that is several years old, but has always given me reliable service, at least until recently.

After upgrading my phone from an iPhone 8+ to a 12 Pro Max, each time I connect the Sena to the phone, it just connects in media mode, not phone mode. I did factory reset the 20S with no change.

I thought maybe there's a firmware update to deal with this. I'm generally pretty good with keeping the device updated (currently running firmware 2.0.4). 

I have tried repeatedly to get the Sena Device Manager to recognize the 20S and each time, I get a message that says "failed to recognize device. cannot open usb." in the Sena Device Manager.

I've tried a number of things including disconnecting all bluetooth devices from my machine, disabling the bluetooth adapter on my machine, disabling Windows driver signing, as well as different ports on my laptop and different cables. None of this has any affect.

I have also run the Sena Device Manager as an administrator, and set it to run in compatibility mode for Windows 7 (my machine is Windows 10 64 bit) again, all with no improvement.

Is there a step I'm missing? I'd just like to update to current firmware to see if that's my issue for phone connection.


Please sign in to leave a comment.