20S firmware 1.7.5 issues

Last weekend I went on a trip with 3 friends, we all have 20S units on the latest firmware.

We always use the group intercom function. We've noticed that from time to time the group got split in two, the two groups (with two Senas in each) could not hear each other. This happened at random, the distance between us was the same and sometimes the "break-up" would last 10 seconds, sometimes longer. Eventually the two groups got joined together again, but it is very annoying when this happens at the moment you want to tell everybody to take an exit. This was never an issue with the previous firmwares.

Another issue, when you're connected (either in a group or directly to one other unit) and you get out of range the unit will start beeping to indicate that it's trying to re-connect. You can only stop this by turning the unit off. I've tried the voice prompt command "End intercom", I tried holding the group-intercom button, I tried pressing the jog-dial button, nothing makes it stop trying to re-connect.

18 commenti

Accedi per aggiungere un commento.